Update je oude OS X

Het is meestal een goed idee om een Mac, als deze een verouderde macOS versie draait, van een nieuwe te voorzien. Bijvoorbeeld omdat Apple de oude macOS versie niet meer ondersteunt.

Soms is het meer nodig dan anders, dat is bijvoorbeeld met ingang van deze maand (oktober 2021) het geval. Want er zijn een aantal ‘root certificaten’ voor SSL verlopen.

Dit artikel gaat vooral over Mac OS X 10.11 (El Capitan) en oudere versies.


Laatste bewerking: 2021-11-28


Leestijd is ongeveer: 6 minutes



Root Certificaten, SSL en TLS

Om precies te zijn gaat het om root certificaten van “Let’s Encrypt”. Dat is niet de eerste de beste uitgever van zogeheten SSL en TLS certificaten. Ze geven er naar eigen zeggen 1,5 miljoen uit. Per dag. Let’s Encrypt is populair omdat hun certificaten gratis zijn.

Bij mijn weten betreft het alleen root certificaten van Let’s Encrypt, niet van andere uitgevers.

Wat root certificaten zijn leg ik nu niet gedetailleerd uit want dat is een technisch verhaal. Het heeft in elk geval te maken met het beveiligen van allerlei dingen die via internet worden geregeld. Zoals websites en email.


Wat moet je nu doen?

Updates en upgrades installeren. Naar de laatste macOS versie die goed draait op jouw model Mac. Als je een oude Mac hebt die geen nieuwere versie kan draaien dan Mac OS X 10.11, moet je misschien een nieuwe Mac aanschaffen.

De minimale macOS versie die je installeren kunt zonder dit probleem is 10.12.1 Sierra.

De getroffen Mac OS X (macOS) versies zijn hoe dan ook verouderd. Je zou deze niet meer moeten gebruiken op een MacBook of andere Mac die je dagelijks gebruikt.

Advies op maat geven in een algemeen artikel…

Gaat lastig. Dus houd ik het algemeen. Installeer grote updates in elk geval niet zomaar.

Technisch is het mogelijk om bijvoorbeeld in één keer van Mac OS X 10.11 (El Capitan) naar macOS 11 (Big Sur) te gaan. Waarbij je in dit voorbeeld vier versies overslaat (10.12, 10.13, 10.14, 10.15).

Uit ervaring weet ik dat het problemen kan geven. Soms worden bepaalde bestanden en instellingen niet goed bijgewerkt. Dan kan het gebeuren dat er na de update iets niet goed werkt

Ik noem hierboven macOS 11 Big Sur omdat deze voor bepaalde modellen Mac de laatste versie is die geïnstalleerd kan worden. Andere Macs kunnen niet hoger dan macOS 10.13 High Sierra, die eigenlijk ook verouderd is. macOS 10.13 heeft geen last van het certificaten-probleem.

Het zijn wel allemaal oude modellen Mac. Maar veel van die oude Macs zijn degelijk en werken na al die jaren nog steeds.

Oude iPhones

Mocht je nog een antiek model iPhone hebben (kan ik mij haast niet voorstellen) dan kan deze kwestie daar ook voorkomen.


Zijn de oude certificaten te los te updaten

Misschien wel. Het betreft ‘root’ certificaten. Vaak kun je deze los downloaden en handmatig installeren. Als ik daarover meer informatie heb werk ik het artikel bij.


Als je je Mac gaat updaten

Kun je soms een paar macOS versies overslaan.

Ga dan – in het geval van een sprong van macOS 10.11 naar macOS 11 (let op de versienummers!) – van 10.11 naar 10.13. Daarna van 10.13 naar 10.15 of 11 (officieus versie 10.16). Een of twee ‘upgrades’ overslaan gaat meestal wel goed.

Maar het is niet gegarandeerd. Wat je ook doet, maak eerst een goede backup van je Mac. Met Time Machine (vind je in Systeemvoorkeuren) of met Carbon Copy Cloner.

Controleer ook, voordat je begint, of je Mac geschikt is voor de nieuwe macOS versie. Kijk ook of er nieuwe drivers zijn voor je randapparatuur, zoals je printer.


Andere redenen om je oude macOS te updaten

Zonder veel verdere uitleg.

  • Je huidige macOS versie is niet meer compatibel. Werkt niet meer met updates van programma’s (apps), nieuwe hardware, websites en andere zaken.
  • Je huidige macOS versie is onveilig. Er zitten veiligheidslekken in die Apple niet meer repareren gaat voor deze macOS versie.
  • De macOS versie op je Mac wordt niet meer ondersteund door Apple. Zoals bijvoorbeeld macOS Sierra (10.12), High Sierra (10.13) en Mojave (10.14).
  • macOS heet op jouw Mac nog ‘Mac OS X’ of ‘OS X’. Dat weet je zeker dat deze verouderd is. Want dat is versienummer 10.11 of ouder en die zijn van 2016 of eerder.

Neem ruim de tijd

Grote updates hebben flink wat tijd nodig om geïnstalleerd te worden. Dat moet je niet ‘even tussendoor’ doen. Plan het zo dat je er genoeg tijd voor hebt en plan extra tijd om andere software te installeren en instellingen te doen.

Naast een macOS update moet je meestal ook updates van programma’s installeren. En ook software die bij je printer en andere hardware hoort.


En dan nog een paar dingen

Oude modellen Mac hebben vaak nog een hard disk aan boord die prima werkt met de geïnstalleerde Mac OS X versie. Als je een update gaat installeren naar macOS Catalina (10.15), Big Sur (11) of Monterey (12) moet je Mac voorzien zijn van een SSD drive.

Want op hard disk draaien deze macOS versies onwerkbaar langzaam. Dus als je Mac een HD heeft, laat deze eerst vervangen.

In de rest van dit artikel noem ik (bewust) de laatste macOS versie niet. Dat is macOS Monterey. Op veel oude Mac modellen kun je Monterey niet installeren.

Leestip: In dit artikel lees je hoe je kunt zien of je Mac geschikt is voor macOS Monterey.

Meer informatie


Als laatste

De kleine lettertjes:

  • De tips op deze pagina zijn als algemeen advies bedoeld.
  • Toepassen van deze tips doe je op eigen risico.
  • Installeren van grote updates veroorzaakt soms een probleem. Wees hierop alert.
  • Als je niet zeker weet of je deze tips zelf kunt uitvoeren, vraag een deskundige om advies. Bijvoorbeeld een lid van het Apple Consultants Network.
  • Bureau de Beer heeft deze tips zorgvuldig samengesteld maar accepteert geen aansprakelijkheid voor eventuele fouten en/of onvolkomenheden.
  • De afbeelding bovenaan deze pagina is van Apple.

Afbeelding bovenaan: Apple

Geef een reactie